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SCED Analysis Guide 
Microsoft Excel 

 

*See Single-case_software table for full overview of analysis techniques capable in each software.  
 

AB-F/U design 

– Example case in Adult Mental Health setting (case description 3) 

 

Practical task resources 
1. Example Excel dataset with idiographic & nomothetic measures (‘AB-FU_datasets.xlsx’) 

2. Reference papers for the nomothetic measures to inform RCSI analysis.  

3. Single-case-V8 Excel workbook and manual for nomothetic RCSI analysis.  

4. Template PowerPoint with tables etc. to input findings to feedback. 

 

Step-by-step guide for analysing the data 

 

1. Open the Excel workbook named ‘AB-FU_datasets.xlsx’ and inspect each tab to get an 

understanding of the case and the data. The first tab contains an overview of the dataset 

including the design, phase lengths and summary of idiographic and nomothetic measures. 

Data for each idiographic measure is included in a separate tab. The final tab contains the 

nomothetic outcomes.  

 

2. Go to the tab for the first idiographic measure (ID1 – Relationship). The data has been 

formatted in the way that is required to produce a plot that will allow you to plot separate 

trend lines for each phase (i.e. with each phase scores in separate columns) using a scatter 

plot rather than a line graph.  

 
Highlight all the data (including 

the column headers in columns 

A, B, C & D (up to row 92). 

Column E is a just for reference. 

Insert a Scatter with Straight 

Lines and Markers  using the 

Insert menu in the screenshot 

below (Insert > Chart > XY 

Scatter > Scatter with Straight 

Lines and Markers).  

 Analysis software Link 

Visual Manually in Excel  n/a 

Baseline trend 
Tau online calculator or  
Tau-U section of Overlap shiny app 

http://ktarlow.com/stats/tau/ 
https://manolov.shinyapps.io/Overlap/ 

Statistical Some manually in Excel.  n/a 

http://ktarlow.com/stats/tau/
https://manolov.shinyapps.io/Overlap/
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3. A time series plot of the data will be produced. Right click on a blank area of the chart. From 

the available options choose ‘Select data’. In the ‘Select data source’ pop-up window, in the 

‘Legend Entries (Series)’ box, select Baseline so it is highlighted. Next, click on the button 

next to the Y values cell to change the selected data cells (see screenshot). The pop-up 

window will minimize – highlight only the cells in column B (Baseline) that contain data 

(rows 2-22) and then press enter to return to the pop-up box. Then, click on the button next 

to the X values cell to change the selected data cells (see screenshot). The pop-up window 

will minimize – highlight only the cells in column A (Days) that have corresponding data in 

the baseline column (rows 2-22) 

and then press enter to return to 

the pop-up box. 

 

Repeat the same process for the 

Intervention and F-U options in the 

‘Legend Entries (Series)’ box. For 

Intervention, select cells C23-C64 

as the Y values and select cells 

A23-64 as the X values. For F-U, 

select cells D65-D92 as the Y values 

and cells A65-A92 as the X values. 

This will then allow you to 

automatically fit a regression trend 

line to the data points in each 

phase separately in step 6. To close 

the Select data source window, 

click OK.  

 

4. To add features to the plot, click on the chart and from the menu click on Chart Design > 

Add Chart Element. From the drop-down menu you can choose to add Horizontal or Vertical 

Axis Titles, a Chart Title or change the Legend if you wish.  

 

To further edit the chart to suit your needs, double click on the plot to open the Format 

panel on the right-hand side. By clicking on different features of the graph you can edit it to 

suit your requirements, including changing the axis scales, selecting different colours for the 

data points and lines, remove vertical and horizontal gridlines and removing the chart 

border. The paper by Dixon et al., (2009) in your resource pack provides more detailed 

guidance on how to edit charts in Excel for single-case plots.  

 

See the AB-FU example results for examples of how an edited and formatted chart can look.  

 

5. To insert the phase-change lines, first make sure you have clicked your mouse on the graph 

to highlight it and not the spreadsheet. If you have the spreadsheet highlighted instead of 

the graph, your phase- change line will end up in the spreadsheet area and not on the 

Select Y values for 
Baseline phase  

Select X values for 
Baseline phase  
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desired graph. After clicking once on the graph to select it, from the menu click Insert > 

Illustrations > Shapes. From the large drop-down menu, select the straight line. Position the 

mouse pointer on the x axis between days 21 and 22 (the end of the baseline and start of 

intervention in this example). Click once to initiate the line, and while holding down the 

mouse button, drag the pointer straight up the graph so that it is parallel with the entire y 

axis. You can ensure that the line will be perfectly vertical (or horizontal) if you hold down 

the shift key while drawing the line. Double click on the line to open the Format panel and 

edit it how you want – such as making it a dashed line or changing the colour. Repeat for the 

other phases.  

 

To label the phases, follow the same process but Insert > Text  > Text Box and draw text 

boxes above each phase and label them accordingly. A final example plot is provided in the 

AB-FU results document. 

 

Note: See Box 1 for more tips on how to customise the plots, such as adding the baseline 

median trend line or axis/phase labels. Alternatively see one of the other Analysis Guides for 

other methods of visually plotting data if you would prefer to use a different method in your 

assignment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. To add phase trend lines, you can either use the Trend Line option in Excel to add 

regression-based trends to each phase or you can manually add split-middle trend lines by 

drawing lines using the same process as adding the phase-change lines (See Box 2 on page 8 

for how to calculate and plot the split-middle trends.)  

 

Box 1: Tips for manually customising plots  

 

Use Word ‘Insert’ and ‘Formatting’ functions to manually customise the plots.  

• Use text boxes to add ‘Baseline’ and ‘Intervention’ labels to phases or a title for the plot if required 

(Insert > Text box). 

• Can also insert text boxes over the axis labels to customize the label to your requirements or to add a 

legend explaining the trend lines etc.. 

• Insert a line to draw the baseline median across all phases or split-middle trend lines in the plot (Insert 

> Illustrations > Shapes > Select line). If you press ‘shift’ when drawing the line it will make sure it is 

horizontal/vertical. Format the shape to change the colour of the line, increase the thickness or make it 

dashed etc.   

• Hold down the ‘shift’ key and select all the added features (text boxes, lines etc.). Without clicking 

anywhere else (so the items all remain selected), right click and select Group > group to combine all the 

added features into one object so they remain in the right place when moving the plot.  

 

See ‘ABAB example results’ document for an example of the ID1_activity.  
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To add the Excel regression trend lines, from the menu click on Chart Design > Add Chart 

Element > Trendline > Linear. A pop-up box will appear and ask which series you want to 

apply the trend line to – select Baseline. A line will appear in the baseline phase. Repeat the 

process and select Intervention and then F-U to add lines to the other phases. You can also 

manually add the median baseline line across all phases by calculating the median of the 

baseline data points and manually inserting a horizontal line at the point that extends across 

all the phases (See plot in example results).  

 

7. When you have finished editing the chart, right-click on it and select ‘Save as picture’. Save 

it to your computer. You can then copy and paste the picture into your assignment (or the 

template PowerPoint provided to feedback the results) without the formatting changing or 

moving.  

 

Note: You can also right-click on the finished plot and select Save as template to save your 

settings. When plotting other idiographic measures or SCED data you can then select this 

chart template, so it is formatted automatically in the style you need.  

 

8. To assess the baseline trend, open the Tau online calculator http://ktarlow.com/stats/tau/. 

Copy the A baseline phase scores for ID1 – relationship from the Excel dataset and paste 

them into the ‘PHASE A (BASELINE)’ box. Copy the B intervention phase scores for ID1 – 

relationship from the Excel dataset and paste them into the ‘PHASE B (TREATMENT)’ box 

(see screenshot). Click ‘Test for Baseline Trend’.  

 

First, establish whether there is a significant 

baseline trend and record the ‘Baseline Trend’ Tau 

value (e.g. TauTrendA=-0.040, p=0.904). Based on the 

significance of the baseline trend, a ‘Recommended 

Effect Size’ is provided.  

 

Click the relevant option – if Baseline Trend is 

significant, select ‘Baseline Corrected Tau’ (will 

produce TauAvsB – trendA) or if Baseline Trend is not 

significant, select ‘Tau (No Baseline Correction)’ 

(will produce TauAvsB). Report the Effect Size 

displayed for the phase A vs B comparison (e.g. 

TauAvsB =0.467, p=0.001). 

 

Note: For your assignment you could assess baseline trend and calculate Tau/Tau-U using 

either the Tau-U online calculator described here or the Tau-U section of the Overlap Shiny 

web app for more detailed output. See Step 6 in the Analysis guide for the Overlap Shiny web 

app for instructions about how to perform and interpret the analysis.  

 

http://ktarlow.com/stats/tau/
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9. PEM, PND and PAND are the overlap statistics that can be computed by hand using the 

visual plot.  

 

PEM 

Manually calculate the median of the baseline phase [can use the formula =MEDIAN(cell 

range of scores)]. Draw a line at the baseline median point across all the phases and count 

how many data points in the intervention phase are above the line if the direction of 

improvement is increase (or below if the direction of improvement is decrease). Convert the 

number to a percentage by dividing by the total number of data points in the intervention 

phase and multiplying by 100.  

 

For example, for ID2_sleep quality (improvement = increase); 

- Baseline median = 3 

- Number of intervention (B) data points above the median = 37 out of a total of 42 

- Convert to a percentage = 37/42*100 = 88.10% 

 

Repeat for the data points in the follow-up (F/U) phase in comparison to the Baseline (A). 

 

PND 

Manually calculate the maximum data point in the baseline phase if the direction of 

improvement is increase [can use the formula =MAXIMUM(cell range of scores)]. Count the 

number of data points in the Intervention phase (B) that are higher than the baseline 

maximum.  

 

If the direction of improvement is decrease, calculate the minimum data point in the 

baseline phase [can use the formula =MINIMUM(cell range of scores)]. Count the number of 

data points in the Intervention phase (B) that are lower than the baseline minimum.  

 

Convert the number to a percentage by dividing by the total number of data points in the 

intervention phase and multiplying by 100.  

 

For example, for ID3_flashbacks (improvement = decrease); 

- Baseline minimum data point = 4 

- Number of intervention (B) data points below the minimum = 6 out of a total of 42 

- Convert to a percentage = 6/42*100 = 14.29% 

 

Repeat for the data points in the follow-up (F/U) phase in comparison to the Baseline (A). 

 

PAND 

Count how many of the extreme data points in either phase would need to be removed so 

that there was no overlap between data points in the two phases. Convert the number to a 

percentage by dividing by the total number of data points in the baseline and intervention 
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phase sand multiplying by 100. Subtract that value from 100 to give the percentage of data 

points that do NOT overlap.  

 

For example, for ID1_relationships (improvement = increase); 

- Minimum number of data points that can be removed from with the baseline of 

intervention phase so there is no overlap = 6 (see red circles in plot below) 

- Total number of data points in A and B phase = 21 + 42 = 63 

- Convert to a percentage of overlapping data points = 6/4(21 + 42)*100 = 9.52% 

- Take the inverse to get % non-overlapping data points = 100 – 9.52 = 90.48% 

 

Repeat for the data points in the follow-up (F/U) phase in comparison to the Baseline (A). 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: For your assignment you may want to produce visual plots in Excel, but use one of the 

Shiny apps to calculate the non-overlap statistics. See the Analysis guides for the SCD-effect-

sizes Shiny app for instructions about how to perform and interpret the outputs.  

 

10. In the Excel dataset use formulas to compute and report the Mean [=AVERAGE(cell range of 

scores)] and SD [=STDEV(cell range of scores)] for each phase separately.  

 

11. Repeat steps 2-10 for the remaining ideographic measures (ID2 – Sleep quality, ID3 - 

Flashbacks).  

 

12. To assess the nomothetic outcomes open the Excel workbook named ‘single-case-V8.xlsm’. 

You may need to enable macros in a pop up box. There is an accompanying manual for 

detailed instructions (‘Manual-for-Leeds-RCI-CSC-calculators.pdf’).  

 
On the ‘Data’ tab, input the Pre-baseline and Post-intervention scores from the ‘Nomothetic 

Outcomes’ tab in the example dataset where indicated. To calculate reliable change, input 

information about the measure including the lowest & highest possible scores, the direction 

of clinical gain and the reliability of the measure (internal consistency Cronbach’s Alpha).You 

will also need to input the SD for clinical norms in cell C27. This information will be available 
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in the psychometric evaluation paper for the measure provided. The box in cell C11 will 

show whether the client has improved, deteriorated or shown no change. In the ‘Results’ 

tab, cell C17 will show the RCI value – amount of change required to be deemed reliable.  

If it makes conceptual sense for the measure to have a clinical threshold, you can also 

determine whether CSC is present. If an established clinical cut-off has been determined in 

the psychometric evaluation of the measure, then use this threshold. If not, the Means and 

SDs of clinical & comparison norms can be inputted on the ‘Data’ tab to produce a clinical 

cut-off value (CSC criteria – see manual for more info on which criterion to use).  

 

Repeat for Pre-baseline score to post-follow-up score.  

 

13. Prepare a brief overview of the findings to feedback to the group (a few PowerPoint slides – 

can use the template provided). Focus on summarising the stages of analysis and 

demonstrating the types of output from the Shiny app (types of visual plots, overlap 

statistics etc.).  
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Box 2: Calculating and plotting the split-middle trend lines  

Appendix 1: How to draw a Split-Middle Trend Line  

Adapted from  J.T. (Tim) Stocks, https://msu.edu/course/sw/830/2008/ssd/01.intro/isd128.htm 

The first step is to obtain two halves of data for each phase. If there are an even number of 

observations, we split the phase into a first half and a second half, e.g., if there were eight observations 

in the phase, the first half would have the first four observations (one through four) and the second 

half would have the last four observations (five through eight).  

If there are an odd number of observations, we do not use the middle observation and the score 

associated with it. The sets of observations on either side of this dropped observation are the halves, 

e.g., if there were nine observations in the phase, we would ignore the fifth observation; the first half 

would have the first four observations (one through four) and the second half would have the last four 

observations (six through nine).  

The second step in obtaining a median is to order scores from least to greatest. We order the first half 

scores and we obtain 1, 1, 3, 3, 3, 4, 5. The median (middle) score is three. The first half observation 

numbers are 1, 2, 3, 4, 5, 6, 7. The median observation number is four. So, we place the first mark on 

the chart at the point defined by observation = 4 and score = 3  

We order the second half scores and obtain 5, 6, 6, 7, 7, 7, 8. The median score is seven. The second 

half observation numbers are 9, 10, 11, 12, 13, 14, 15. The median observation number is twelve. We 

place our second mark at the point defined by observation = 12 and score = 7  

We draw a straight line through the two marks to create the split-middle trend line. 

 

To visually interpret the data, we extend the split-middle trend line into the next phase to make 

comparisons across phases. 

We repeat the procedure for each phase.  

 

 

  

https://msu.edu/course/sw/830/2008/ssd/01.intro/isd128.htm

